Search found 1 match

by kristin
Thu Mar 09, 2017 8:57 am
Forum: Help
Topic: Timetrex "severely out of date"
Replies: 1
Views: 1229

Timetrex "severely out of date"

When signing on to Timetrex, the following error appears across the top: "WARNING: This TimeTrex version (v9.0.9) is severely out of date and may no longer be supported. Please upgrade to the latest version as soon as possible as invalid calculations may already be occurring". How do we push this up...