Timetrex with PHP version 7.1.7

Ask your questions regarding TimeTrex installation here.
Post Reply
jasonfilz
Posts: 2
Joined: Thu Aug 17, 2017 9:48 am

Timetrex with PHP version 7.1.7

Post by jasonfilz » Thu Aug 17, 2017 11:15 am

Manual install on existing Windows server (yea I know Linux is better - but have to deal with what is given) with PostreSQL database.

I am getting this error on installation.

Checking pre-flight requirements... 1... 2... 3... 4...You are currently using PHP v7.1.7 TimeTrex requires PHP v7.0.x or earlier!
I don't want to downgrade the PHP version. Why the limit with 7.1? anything like:
http://php.net/manual/en/migration71.incompatible.php

When fixed?

shaunw
Posts: 7455
Joined: Tue Sep 19, 2006 2:22 pm

Re: Timetrex with PHP version 7.1.7

Post by shaunw » Thu Aug 17, 2017 1:08 pm

TimeTrex hasn't been tested on PHP v7.1 yet, so until that is done the installer will fail.

Since v7.1 isn't in any stable Linux releases yet, and our automated installer uses v7.0, supporting bleeding edge PHP versions it not a high priority, but we will likely get around to testing it in early 2018.

jasonfilz
Posts: 2
Joined: Thu Aug 17, 2017 9:48 am

Re: Timetrex with PHP version 7.1.7

Post by jasonfilz » Fri Aug 18, 2017 12:43 am

As stated - NOT a Linux server! Windows install only allows MySQL - and we have PostgreSQL due to ERP (which TimeTrex does support - though not really identified anywhere). Server already running Apache and PHP and there is NO instructions on how to manual install or specifications needed for Windows server. Your Windows install is lacking customization for existing servers.

PHP 7.1 not stable? Php 7.1.0 came out stable back in Dec 2016 and really the specifications (via early version) has been out since June 9 2016 (over a year ago) and 7.2 is about to be released (Beta 3 released just yesterday). Why not stable? On PHP its been stable for more than half a year? 7.2 is considered NOT stable and been out for 2 months now.

Sounds like a typical open source software - we get to it some time in a year or two or sooner if some one want to pay for it now.

Looks like they removed functions that was depreciated several versions ago - which by now should have been changed for anyone using 7.0 anyway. They added more functions and a few changes needed to be version 7.1 compatible.

You should up date to version 7.1 but vector to be compatible to version 7.2 so in a year or so when you get to updating it you have the compatibility for 7.2 when that is stable later this year or early next year.

It was not my server but said that is what was updated to.

shaunw
Posts: 7455
Joined: Tue Sep 19, 2006 2:22 pm

Re: Timetrex with PHP version 7.1.7

Post by shaunw » Fri Aug 18, 2017 7:24 am

TimeTrex is of course open source, so we always welcome people to contribute back to the community.

cassbiz
Posts: 1
Joined: Wed Dec 20, 2017 1:02 pm

Re: Timetrex with PHP version 7.1.7

Post by cassbiz » Fri Jan 05, 2018 11:25 am

Is there a time frame of when it will be tested with PHP 7.1.7?

Running Mac OS X High Sierra

shaunw
Posts: 7455
Joined: Tue Sep 19, 2006 2:22 pm

Re: Timetrex with PHP version 7.1.7

Post by shaunw » Sat Jan 06, 2018 12:23 pm

cassbiz wrote:
Fri Jan 05, 2018 11:25 am
Is there a time frame of when it will be tested with PHP 7.1.7?
No specific time frame other than early 2018. If I had to guess it would likely be after the year-end rush calms down around March.

Post Reply