Failed Install on IIS Server

Ask your questions regarding TimeTrex installation here.
Post Reply
nonsense
Posts: 1
Joined: Thu Jan 04, 2018 12:17 am

Failed Install on IIS Server

Post by nonsense » Thu Jan 04, 2018 12:37 am

Hello

I have bee trying install timetrex with manual method on IIS machine always not luck got error message like screenshot below:
error.PNG
error.PNG (43.84 KiB) Viewed 272 times
Its my timetrex.ini.php config below:
;<?php die('Unauthorized Access...'); //SECURITY MECHANISM, DO NOT REMOVE//?>
;
;
; TimeTrex Configuration File
; *Windows Example*
;
;

;
; System paths. NO TRAILING SLASHES!
;
[path]
;URL to TimeTrex web root directory. ie: http://your.domain.com/<*BASE_URL*>
;DO NOT INCLUDE http://your.domain.com, just the directory AFTER your domain
base_url = "/interface"

;
;Log directory -- NOTICE: For security reasons, this should always be outside the web server document root.
;
log = "C:\inetpub\timetrex\log"

;
;Misc storage, for attachments/images -- NOTICE: For security reasons, this should always be outside the web server document root.
;
storage = "C:\inetpub\timetrex\storage"

;
;Full path and name to the PHP CLI Binary
;
php_cli = "C:\Program Files\PHP\v7.1\php-win.exe"



;
; Database connection settings. These can be set from the installer.
;
[database]
database_name = timetrax
host = "102.xxx.xxx.xxx"
password = abcdefgh
type = postgres
user = adminroot


;
; Email delivery settings.
;
[mail]
;Least setup, deliver email through TimeTrex's email relay via SOAP (HTTP port 80/443)
delivery_method = soap

;Deliver email through remote SMTP server with the following settings.
; delivery_method = smtp
; smtp_host=smtp.gmail.com
; smtp_port=587
; smtp_username=timetrex@gmail.com
; smtp_password=testpass123

;The domain that emails will be sent from, do not include the "@" or anything before it.
; *ONLY* specify this if "delivery_method" above is "smtp"
;email_domain = wallezz.com

;The local part of the email address that emails will be sent from, do not include the "@" or anything after it.
; *ONLY* specify this if "delivery_method" above is "smtp"
;email_local_part = DoNotReply


;
; Cache settings
;
[cache]
enable = TRUE
;NOTICE: For security reasons, this should always be outside the web server document root.
dir = C:\inetpub\timetrex\temp



[debug]
;Set to false if you're debugging
production = TRUE

enable = FALSE
enable_display = FALSE
buffer_output = TRUE
enable_log = FALSE
verbosity = 10



[other]
; Force all clients to use SSL.
force_ssl = FALSE
installer_enabled = TRUE
primary_company_id = 0

;Specify the URL hostname to be used to access TimeTrex. The BASE_URL specified above will be appended on to this automatically.
; This should be a fully qualified domain name only, do not include http:// or any trailing directories.
hostname = localhost

;ONLY when using a fully qualified hostname specified above, enable CSRF validation for increased security.
;enable_csrf_validation = TRUE

; System Administrators Email address to send critical errors to if necessary. Set to FALSE to disable completely.
;system_admin_email = "sysadmin@mydomain.com"

;WARNING: DO NOT CHANGE THIS AFTER YOU HAVE INSTALLED TIMETREX.
;If you do it will cause all your passwords to become invalid,
;and you may lose access to some encrypted data.
salt = 0
So How I can fix it?

Regards

shaunw
Posts: 7483
Joined: Tue Sep 19, 2006 2:22 pm

Re: Failed Install on IIS Server

Post by shaunw » Thu Jan 04, 2018 1:09 pm

TimeTrex does not currently support PHP v7.1.X, only v7.0.X and older.

shaunw
Posts: 7483
Joined: Tue Sep 19, 2006 2:22 pm

Re: Failed Install on IIS Server

Post by shaunw » Thu Mar 08, 2018 1:42 pm

I was informed that TimeTrex v11.2.0 due out in the next week or two will include support for PHP up to v7.2.

Post Reply