TimeTrex_Community_Edition_v9.1.2 on Linux 4.4.0-31-generic

Ask your questions regarding TimeTrex installation here.
Post Reply
DrK
Posts: 8
Joined: Fri Jul 29, 2016 1:03 am

TimeTrex_Community_Edition_v9.1.2 on Linux 4.4.0-31-generic

Post by DrK » Fri Jul 29, 2016 2:03 am

TimeTrex_Community_Edition_v9.1.2 on Linux 4.4.0-31-generic #50-Ubuntu SMP
See below for error when executing the install via Firefox
Capture3.PNG
phpinfo() output starts...
PHP Version 7.0.8-0ubuntu0.16.04.1

Configuration File (php.ini) Path /etc/php/7.0/apache2
Loaded Configuration File /etc/php/7.0/apache2/php.ini
Scan this dir for additional .ini files /etc/php/7.0/apache2/conf.d


From timetrex.ini.php...
;Full path and name to the PHP CLI Binary
;
;Linux
;php_cli = /usr/bin/php
php_cli = /usr/lib/php/7.0


;
; Database connection settings. These can be set from the installer.
;
[database]
type = mysqli
;type = postgres8

host = localhost
database_name = timetrex
user = timetrex
password = "ENTER_PASSWORD_HERE"


Last entry in timetrex.log...
---------------[ 28-Jul-2016 14:29:22 +0100 [1469712562.1742] (PID: 14109) ]---------------
DEBUG [L0138] [00043ms]: [Function](): Checking requirements only...
DEBUG [L0141] [00043ms]: [Function](): Launched from web installer...
DEBUG [L0738] [00043ms]: Install::checkPHPVersion(): Comparing with Version: 7.0.8-0ubuntu0.16.04.1
DEBUG [L1199] [00043ms]: Install::checkPHPOpenBaseDir(): Open BaseDir:
DEBUG [L0738] [00043ms]: Install::checkPHPVersion(): Comparing with Version: 7.0.8-0ubuntu0.16.04.1
DEBUG [L1199] [00043ms]: Install::checkPHPOpenBaseDir(): Open BaseDir:
---------------[ 28-Jul-2016 14:29:22 +0100 [1469712562.217] (PID: 14109) ]---------------

There are 2 php.ini of course, /etc/php/7.0/apache2 and /etc/php/7.0/cli
Both are set with sql.safe_mode = Off
Neither have any include_path variables set.

????????
Where do I look next please?

shaunw
Posts: 7353
Joined: Tue Sep 19, 2006 2:22 pm

Re: TimeTrex_Community_Edition_v9.1.2 on Linux 4.4.0-31-gen

Post by shaunw » Fri Jul 29, 2016 9:32 am

In the red error message, there is a command, copy that full and exact command (it spans several lines by the looks of it) into a shell and paste the output here.

DrK
Posts: 8
Joined: Fri Jul 29, 2016 1:03 am

Re: TimeTrex_Community_Edition_v9.1.2 on Linux 4.4.0-31-gen

Post by DrK » Mon Aug 01, 2016 3:55 am

Hi, well taken verbatim, I just get an error:

matt@quincy:/var/www/html/timetrex/tools$ "/usr/lib/php/7.0" "/var/www/html/timetrex/tools/unattended_upgrade.php" --config "/var/www/html/timetrex/includes/../timetrex.ini.php" --requirements_only --web_installer
bash: /usr/lib/php/7.0: Is a directory

But adapting the command to something useful, it is ok:
matt@quincy:/var/www/html/timetrex/tools$ sudo php -f unattended_upgrade.php -- config "/var/www/html/timetrex/includes/../timetrex.ini.php" --requirements_only --web_installer
Requirements all pass successfully!

How can I help next?
Thanks.
Matt

shaunw
Posts: 7353
Joined: Tue Sep 19, 2006 2:22 pm

Re: TimeTrex_Community_Edition_v9.1.2 on Linux 4.4.0-31-gen

Post by shaunw » Mon Aug 01, 2016 11:54 am

Okay, the issue is that in your timetrex.ini.php file, you specified a directory for your PHP CLI binary, not the binary executable itself:
;Linux
;php_cli = /usr/bin/php
php_cli = /usr/lib/php/7.0
That should be pointing to the full and exact PHP binary executable file, something like this:

Code: Select all

;Linux
;php_cli = /usr/bin/php
php_cli = /usr/lib/php/7.0/php

DrK
Posts: 8
Joined: Fri Jul 29, 2016 1:03 am

Re: TimeTrex_Community_Edition_v9.1.2 on Linux 4.4.0-31-gen

Post by DrK » Tue Aug 02, 2016 1:41 am

:D That's a fix -thank you.
On to next level of install joy!

Post Reply