local chache has expired.

Ask your questions regarding TimeTrex installation here.
Post Reply
jarrett125
Posts: 125
Joined: Tue Aug 23, 2016 11:44 am

local chache has expired.

Post by jarrett125 » Wed Aug 31, 2016 11:24 am

hi

during the start of the installation after you press the check box and click the next arrow i get this message

Local Cache has expired. click ok to reload.

;
; Cache settings
;
[cache]
enable = TRUE
;Linux
dir = /var/www/html/timetrex/cache


in that file path i have a blank cache folder

jarrett125
Posts: 125
Joined: Tue Aug 23, 2016 11:44 am

Re: local chache has expired.

Post by jarrett125 » Wed Aug 31, 2016 11:34 am

i have tired to use ip vs localhost both fail out on me. i would post log info but idk where its going to where to look

ubuntu 16.04
apache 2.4.18
postgresql 9.5.4
php 7.0.8

jarrett125
Posts: 125
Joined: Tue Aug 23, 2016 11:44 am

Re: local chache has expired.

Post by jarrett125 » Wed Aug 31, 2016 11:43 am

;<?php die('Access denied...');?>

;
; TimeTrex Configuration File
; *Linux* Example
;
;

;
; System paths. NO TRAILING SLASHES!
;
[path]
;URL to TimeTrex web root directory. ie: http://your.domain.com/<*BASE_URL*>
;DO NOT INCLUDE http://your.domain.com, just the directory AFTER your domain
base_url = /timetrex/interface

;
;log directory
;
;Linux
log = /var/www/html/timetrex/log

;
;Misc storage, for attachments/images
;
;Linux
storage = /var/www/html/timetrex/storage

;
;Full path and name to the PHP CLI Binary
;
;Linux
php_cli = /usr/bin/php



;
; Database connection settings. These can be set from the installer.
;
[database]
;type = mysqli
type = postgres8

host = localhost
database_name = timetrex
user = timetrex
password = "ENTER_PASSWORD_HERE"


;
; Email delivery settings.
;
[mail]
;Least setup, deliver email through TimeTrex's email relay via SOAP (HTTP port 80)
delivery_method = soap

;Deliver email through local sendmail command specified in php.ini
;delivery_method = mail

;Deliver email through remote SMTP server with the following settings.
;delivery_method = smtp
;smtp_host=smtp.gmail.com
;smtp_port=587
;smtp_username=timetrex@gmail.com
;smtp_password=testpass123


;
; Cache settings
;
[cache]
enable = TRUE
;Linux
dir = /var/www/html/timetrex/cache



[debug]
;Set to false if you're debugging
production = FALSE

enable = TRUE
enable_display = TRUE
buffer_output = TRUE
enable_log = TRUE
verbosity = 10



[other]
; Force all clients to use SSL.
force_ssl = FALSE
installer_enabled = TRUE
primary_company_id = 0
hostname = localhost

; System Administrators Email address to send critical errors to if necessary. Set to FALSE to disable completely.
;system_admin_email = "sysadmin@mydomain.com"

default_interface = html5

;WARNING: DO NOT CHANGE THIS AFTER YOU HAVE INSTALLED TIMETREX.
;If you do it will cause all your passwords to become invalid,
;and you may lose access to some encrypted data.
salt = 0

jarrett125
Posts: 125
Joined: Tue Aug 23, 2016 11:44 am

Re: local chache has expired.

Post by jarrett125 » Wed Aug 31, 2016 12:03 pm

Also I have tried clearing Web browser cache and on a remote system

jarrett125
Posts: 125
Joined: Tue Aug 23, 2016 11:44 am

Re: local chache has expired.

Post by jarrett125 » Wed Aug 31, 2016 12:30 pm

behind the local cache has expired box i see
invaid,pgsql or mysqliphp extensions are required.

jarrett125
Posts: 125
Joined: Tue Aug 23, 2016 11:44 am

Re: local chache has expired.

Post by jarrett125 » Wed Aug 31, 2016 12:39 pm

see attachment for error screenshot
weberror2.png

jarrett125
Posts: 125
Joined: Tue Aug 23, 2016 11:44 am

Re: local chache has expired.

Post by jarrett125 » Wed Aug 31, 2016 1:00 pm

i also made sure every file for timetrex has 777 permissions so there is no way its a permissions issues

psymin
Posts: 5
Joined: Wed Sep 07, 2016 9:45 am

Re: local chache has expired.

Post by psymin » Thu Sep 08, 2016 8:59 am

I had this issue for a while as well upon install.

Try opening this page instead:

http://10.0.16.209/timetrex/interface/i ... icense.php

jarrett125
Posts: 125
Joined: Tue Aug 23, 2016 11:44 am

Re: local chache has expired.

Post by jarrett125 » Mon Sep 12, 2016 1:01 pm

thankyou for your reply i was able to get it working. if i remember right it had to do with php missing something with apache i think it was i just forgot to install apache2 extension for php

Post Reply