Issues after version upgrade

Ask your questions regarding TimeTrex installation here.
Post Reply
handleric
Posts: 6
Joined: Mon Mar 11, 2019 6:41 pm

Issues after version upgrade

Post by handleric »

Hello,

after the last automatic upgrade hit my instance, im again seeing errors on the user interface and rerunning the installer is complaining about missing dependencies:

In the installer, it shows:
PHP Version: Unsupported (V7.3.3)
ZIP Enabled: Not Installed. (ZIP extension must be enabled)
PHP DISABLE_FUNCTIONS: Ok
PHP CLI Requirements: PHP CLI requirements failed while executing
"/usr/bin/php" "/var/www/html/timetrex/tools/unattended_upgrade.php" --config "/var/www/html/timetrex/includes/../timetrex.ini.php" --requirements_only --web_installer
Likely caused by having two PHP.INI files with different settings.

Detailed Error Messages

PHP CLI Requirements Output:
----WARNING----WARNING----WARNING-----
--------------------------------------
Minimum PHP Requirements are NOT met!!
--------------------------------------
Failed Requirements: PHPVersion,ZIP
--------------------------------------
PHP INI: /etc/php.ini
Process Owner: apache
--------------------------------------


My instance is running on CentOS 7 with Postgresql and PHP 7.3. Running yum list installed, I can see php73-php-pecl-zip.x86_64 listed as installed.

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Issues after version upgrade

Post by mikeb »

Can you please confirm the exact version of TimeTrex that you are using?
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

handleric
Posts: 6
Joined: Mon Mar 11, 2019 6:41 pm

Re: Issues after version upgrade

Post by handleric »

the version on the login page states v11.5.0-20190301-035201

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Issues after version upgrade

Post by mikeb »

Please upgrade to the latest version (v11.5.1) and try again.
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

handleric
Posts: 6
Joined: Mon Mar 11, 2019 6:41 pm

Re: Issues after version upgrade

Post by handleric »

@mikeb - I manually upgraded to 11.5.1 as you suggested and it seems to have resolved the PHP version error, but i'm still getting an error about the ZIP extension dependency. Being that PHP_73 is the installed PHP package, php73-php-pecl-zip.x86_64 should be the proper package to run correct?


PHP CLI requirements failed while executing
"/usr/bin/php" "/var/www/html/timetrex/tools/unattended_upgrade.php" --config "/var/www/html/timetrex/includes/../timetrex.ini.php" --requirements_only --web_installer
Likely caused by having two PHP.INI files with different settings.Detailed Error Messages

PHP CLI Requirements Output:
----WARNING----WARNING----WARNING-----
--------------------------------------
Minimum PHP Requirements are NOT met!!
--------------------------------------
Failed Requirements: ZIP
--------------------------------------
PHP INI: /etc/php.ini
Process Owner: apache
--------------------------------------

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Issues after version upgrade

Post by mikeb »

Yes, you will need to install the PHP-ZIP extension in the normal way to do that for your specific PHP instance.
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

handleric
Posts: 6
Joined: Mon Mar 11, 2019 6:41 pm

Re: Issues after version upgrade

Post by handleric »

@mikeb - in initial inspection the extension was already installed (wasn't it always a requirement?). I did go ahead and remove and reinstall it which made the detailed error message go away and it no longer says "Failed PHP CLI Requirements Output", but although that message about the zip extension cleared the one above next to "Zip enabled" still says not installed.

How is it possible that one validation can determine the ZIP extension in installed and healthy, but the other function validating the same thing clears? Do you thing this is an application bug?

I have again confirmed that php-pecl-zip.x86_64 is installed and functioning.

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Issues after version upgrade

Post by mikeb »

PHP extensions can be "installed" but not "enabled". Please make sure that your ZIP extension is both installed and enabled.

Additionally, extensions can be installed/enabled for PHP when used from a web server, but not for PHP when used from the command line (CLI). So you need to make sure its installed/enabled for both the web server and CLI.
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

Post Reply