Upgrade completed unable to login

Ask your questions regarding TimeTrex installation here.
Post Reply
rdmstrs
Posts: 4
Joined: Thu Jul 02, 2020 7:57 am

Upgrade completed unable to login

Post by rdmstrs »

I upgraded yesterday to 12.1.3 and after the upgrade when i attempt to login i receive the following error: "Timetrex-Debug is currently undergoing mainenance. We apologize for any inconvenience this may cause, please try again later. (INSTALL)

rdmstrs
Posts: 4
Joined: Thu Jul 02, 2020 7:57 am

Re: Upgrade completed unable to login

Post by rdmstrs »

I have attached the debug log.
It is installed on server 2012 r2
Attachments
timetrex.log
(1.84 MiB) Downloaded 69 times

rdmstrs
Posts: 4
Joined: Thu Jul 02, 2020 7:57 am

Re: Upgrade completed unable to login

Post by rdmstrs »

I changed the lines in the timetrex.ini.php file for production from false to true and for installer_enabled from true to false before i ran that debug log and attached is the error i am getting after making those changes.
Attachments
timetrex error2.JPG
timetrex error2.JPG (23.64 KiB) Viewed 1523 times

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Upgrade completed unable to login

Post by mikeb »

It appears as though you may have attempted an upgrade from an earlier version of TimeTrex of never fully completed it, as the database schema wasn't upgraded. Try setting installer_enabled=true in the timetrex.ini.php file and run the web-based installer again (install/install.php), that should fix it for you.
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

rdmstrs
Posts: 4
Joined: Thu Jul 02, 2020 7:57 am

Re: Upgrade completed unable to login

Post by rdmstrs »

That worked! Thanks and just for anyone else that may come across this I did what Mike stated, but to clarify running install/install.php required me to open my normal timetrex in the browser and replace everything after interface/ with install/install.php and after that install completed i had to edit the timetrex.ini.php file and change the installer_enabled back to false.

Post Reply