Requirement Check Failed

Ask your questions regarding TimeTrex installation here.
Post Reply
nth0mth0m
Posts: 29
Joined: Fri Nov 15, 2019 9:39 pm

Requirement Check Failed

Post by nth0mth0m »

Hello all,

I have started to get a Requirement check failed RED bar at the top. I believe this may have to do with it (from logs):
Couple things to note here is that I have added

disable_auto_upgrade = TRUE

as I would like to manually upgrade whenever possible. Not sure if this log is related to the auto upgrade but seems like it.... How can I get rid of the error?




---------------[ 16-Aug-2020 2:30:02 -0600 [1597566602.8271] (PID: 7098) ]---------------
DEBUG [L3128] [00095ms]: Misc::getCurrentOSUser(): POSIX extension not installed, unable to determine webserver user...
DEBUG [L0979] [00095ms]: Install::checkPHPVersion(): Comparing with Version: 7.3.11
DEBUG [L0553] [00105ms]: TTi18n::chooseBestLocale(): Unable to find and set a locale.
DEBUG [L0347] [00105ms]: TTDate::setTimeZone(): TimeZone already set to: America/Denver
DEBUG [L0152] [00105ms]: GLOBAL: Version: 12.0.2 (PHP: v7.3.11) Edition: 10 Production: 1 Server: N/A Database: Type: postgres8 Name: timetrex Config: /var/www/html/includes/../timetrex.ini.php Demo Mode: 0
DEBUG [L0172] [00107ms]: GLOBAL: Lock File: /tmp/timetrex/UnAttended_Upgrade_3584395684.lock
DEBUG [L0084] [00107ms]: LockFile::getCurrentPID(): Current PID: 7098
DEBUG [L0268] [00107ms]: GLOBAL: Checking requirements only...
DEBUG [L0271] [00107ms]: GLOBAL: Launched from web installer...
DEBUG [L2606] [00107ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00107ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_7 Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00109ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_f Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00110ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_8 Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00111ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_c Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00111ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_a Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00112ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_4 Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00113ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_2 Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00114ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_9 Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00114ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_3 Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00115ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_0 Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00115ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_b Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00116ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_6 Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L2606] [00116ms]: Misc::cleanDir(): Cleaning: /tmp/timetrex/cache_1 Exclude Regex: \.ZIP|\.lock|.state|upgrade_staging
DEBUG [L0979] [00116ms]: Install::checkPHPVersion(): Comparing with Version: 7.3.11
DEBUG [L1562] [00117ms]: Install::checkPHPOpenBaseDir(): Open BaseDir:

shaunw
Posts: 7670
Joined: Tue Sep 19, 2006 2:22 pm

Re: Requirement Check Failed

Post by shaunw »

The error you are seeing has nothing to do with auto-upgrades. It has to do with the fact that the system requirements are no longer being met, so likely something has changed on your server to break things.

The log you pasted isn't related, but if you enable the web installer in the .ini file then re-run that, it will give you a detailed message as to what the problem is. Usually its something like permissions having changed to a directory and TimeTrex can no longer write to it.

nth0mth0m
Posts: 29
Joined: Fri Nov 15, 2019 9:39 pm

Re: Requirement Check Failed

Post by nth0mth0m »

Very strange.

I enabled the installer and immediately I got "1.2.3... PASSED" (or something of that nature... it was rather fast, After it took me the terms, clicking agree, after agreeing to the terms I got a could not connect error. Network connect lost. Internal 500 error... Clicking close and retrying worked. Then on to database, which connected, and the upgrade database which worked... I no longer get the error message when logging in. Seems like there was no issue. What do you think caused this, this happens periodically?

shaunw
Posts: 7670
Joined: Tue Sep 19, 2006 2:22 pm

Re: Requirement Check Failed

Post by shaunw »

You would need to check the PHP error log and TimeTrex log file from the date that the original notification message appeared to know for sure.

Whenever possible, the installer does attempt to fix any errors it finds on its own, so its possible it was able to do that in this case.

nth0mth0m
Posts: 29
Joined: Fri Nov 15, 2019 9:39 pm

Re: Requirement Check Failed

Post by nth0mth0m »

Hello there. I am still getting the error parodically. When I rerun the installer everything passes and the error goes away. Eventually it comes back. Upon looking at the timetrex logs, I only get the same errors that I posted prior. As far as php error, I only get the following (is this related?)

[Sat Sep 26 11:01:36.968468 2020] [proxy_fcgi:error] [pid 17513:tid 140039421916928] [client 139.59.174.107:32884] AH01071: Got error 'Primary script unknown'
[Sun Sep 27 05:45:52.382796 2020] [proxy_fcgi:error] [pid 18947:tid 140039396738816] [client 37.187.132.132:41234] AH01071: Got error 'Primary script unknown'
[Sun Sep 27 11:12:33.181521 2020] [proxy_fcgi:error] [pid 17513:tid 140039463880448] [client 212.83.149.170:58791] AH01071: Got error 'Primary script unknown'
[Sun Sep 27 12:20:57.949808 2020] [proxy_fcgi:error] [pid 17513:tid 140039592945408] [client 149.28.102.92:49090] AH01071: Got error 'Primary script unknown'
[Mon Sep 28 20:20:54.670255 2020] [cgid:error] [pid 18947:tid 140039388346112] [client 202.69.171.52:39662] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:20:54.673073 2020] [cgid:error] [pid 17512:tid 140039489058560] [client 202.69.171.52:42586] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:20:54.677151 2020] [cgid:error] [pid 17514:tid 140039145056000] [client 202.69.171.52:58259] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:20:54.686303 2020] [cgid:error] [pid 18947:tid 140039455487744] [client 202.69.171.52:62419] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:50:55.691669 2020] [cgid:error] [pid 17513:tid 140039489058560] [client 202.69.171.52:51038] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:50:55.691692 2020] [cgid:error] [pid 18947:tid 140039567767296] [client 202.69.171.52:39270] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:50:55.709602 2020] [cgid:error] [pid 17512:tid 140039567767296] [client 202.69.171.52:48713] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:51:05.829436 2020] [cgid:error] [pid 17513:tid 140039430309632] [client 202.69.171.52:18786] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:52:53.885049 2020] [cgid:error] [pid 17513:tid 140039388346112] [client 202.69.171.52:48239] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:52:53.888866 2020] [cgid:error] [pid 17512:tid 140039413524224] [client 202.69.171.52:2043] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:52:53.888963 2020] [cgid:error] [pid 17514:tid 140039245768448] [client 202.69.171.52:53996] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet
[Mon Sep 28 20:52:56.782945 2020] [cgid:error] [pid 18947:tid 140039363168000] [client 202.69.171.52:55559] AH01264: script not found or unable to stat: /var/www/cgi-bin/kerbynet

shaunw
Posts: 7670
Joined: Tue Sep 19, 2006 2:22 pm

Re: Requirement Check Failed

Post by shaunw »

You will need to send us your entire timetrex.log file, it will let us know exactly whats happening as long as its from the proper day where the issue first appeared.

Post Reply