PHP Deprecated and format PHP errors

Ask your questions regarding TimeTrex installation here.
Post Reply
MedZec
Posts: 2
Joined: Tue Mar 23, 2021 1:35 pm

PHP Deprecated and format PHP errors

Post by MedZec »

Version 12.7
Postgres 13
PHP 8.0 and 7.4.5
Windows Server 2012
IIS Server
Installed from Zip several years ago


PHP error Logs running on both 8.0 or 7.4.5 complain about :

PHP 7.4.5 error log:
these arrive in waves of approx 10 with activity. If the system is idle they don't seem to accumulate:

Code: Select all

[23-Mar-2021 17:08:00 America/Los_Angeles] PHP Deprecated:  Invalid characters passed for attempted conversion, these have been ignored in C:\inetpub\wwwroot\TimeTrex\classes\modules\core\TTUUID.class.php on line 96
When I switch to 8.0.0, the errors come every minute and with activity.
PHP 8.0 error logs :

Code: Select all

[24-Mar-2021 00:27:00 GMT] PHP Deprecated:  Required parameter $epoch follows optional parameter $format in C:\inetpub\wwwroot\TimeTrex\classes\modules\core\TTDate.class.php on line 967
[23-Mar-2021 17:27:00 America/Los_Angeles] PHP Deprecated:  Invalid characters passed for attempted conversion, these have been ignored in 
Every few days there are over 20,000 lines accumulate

shaunw
Posts: 7670
Joined: Tue Sep 19, 2006 2:22 pm

Re: PHP Deprecated and format PHP errors

Post by shaunw »

Are you using a 32-bit or 64-bit version of PHP?

MedZec
Posts: 2
Joined: Tue Mar 23, 2021 1:35 pm

Re: PHP Deprecated and format PHP errors

Post by MedZec »

Looks like it is the 32 bit version of PHP. Used both 7.45 and 8.0

I used the 7.45 that comes with the install and copied the PHP folder to the drive. Seems to be working without the errors every second. Is TimeTrex using 64 bit now?

shaunw
Posts: 7670
Joined: Tue Sep 19, 2006 2:22 pm

Re: PHP Deprecated and format PHP errors

Post by shaunw »

TimeTrex has only supported 64-bit operating systems and stack components since 2017. Windows Server 2012 is also not supported. You can see the requirements here:
viewtopic.php?f=6&t=6

Additionally I recommend that you upgrade to TimeTrex v12.7.1 as it will help with some of those errors too.

Post Reply