Modified index.php, now receiving checksum error/warning

General support regarding TimeTrex, such as
configuring policies/taxes or processing payroll.
Post Reply
grayfox
Posts: 4
Joined: Fri May 05, 2017 12:41 pm

Modified index.php, now receiving checksum error/warning

Post by grayfox » Mon May 15, 2017 1:03 pm

Hello,

We have TimeTrex (10.6.0) Community Edition on a Debian VM (manual install), and it's been running great in testing. I recently made a change to the index.php page located under /interface/html5, and we're now receiving a warning banner that the installer needs to be re-run. I reran the installer, and received a message stating that the checksum for index.php does not match (clearly because I've edited the file). Is there a way to disable the warning message? If not, is there a way I can disable checksum validations for just that file? If that's not possible, is there a way to disable the question on the footer which asks "How are you liking TimeTrex, answer in smilies", etc? I simply commented out the section containing the question and smilies when I modified the file.

I did search the forums and saw posts related to disabling display errors in the php ini file, but that yielded no change. Also, I did restore the original/stock index.php, but the message does not disappear. Is there a particular way I would need to go about restoring the file? Thank you for your help.

grayfox
Posts: 4
Joined: Fri May 05, 2017 12:41 pm

Re: Modified index.php, now receiving checksum error/warning

Post by grayfox » Wed May 17, 2017 2:30 pm

I ended up modifying the files.sha1 file containing all of the hash checksums to correspond with the edited version of the index.php file. A workaround, but it works. It would be nice to disable warnings, or at least limit them to administrators, however. Just posting in case it helps anyone. Thanks.

Post Reply