large size of debug log file timetrex.log - turning it off

Topics brought up by the TimeTrex open source community.
Locked
andy
Posts: 19
Joined: Mon Aug 18, 2008 1:08 pm

large size of debug log file timetrex.log - turning it off

Post by andy »

We noticed that the file ~/Timetrex/log/timetrex.log was getting huge, with many DEBUG lines added per punch. Since things are working ok, we didn't want the disk space used up as the log grew. Tech Support explained how to turn off the logging:

Edit the file ~/Timetrex/timetrex/timetrex.ini.php
Make these 3 changes:
buffer_output = FALSE
enable_log = FALSE
verbosity = 0

It is not necessary to restart Timetrex.
You can "erase" the old file with:
echo > timetrex.log

Have a nice log-free day!
-A

Locked