Delicious      Technorati      Blinklist      Furl      Reddit

TimeTrex Time and Attendance

TimeTrex Time and Attendance


* FAQ    * Search
* Login   * Register

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Dec 01, 2014 7:40 am 
Offline

Joined: Mon Dec 01, 2014 7:12 am
Posts: 2
During updating to v7.4.7 the following message appears:
Quote:
Warning: PHP CLI requirements failed while executing
""C:\php\php-win.exe" "C:\timetrex\/tools/unattended_upgrade.php" --config "C:\timetrex\includes\..\timetrex.ini.php" --requirements_only --web_installer"
Likely caused by having two PHP.INI files with different settings.

Since this is a windows machine it becomes obvious that the slashes in the path are linux slashes.

the error is in /classes/modules/install/install.class.php:1152

it says:
Code:
$command = '"'. $this->getPHPCLI() .'" "'. Environment::getBasePath() .'/tools/unattended_upgrade.php" --config "'. CONFIG_FILE .'" --requirements_only --web_installer';
it should say:
Code:
$command = '"'. $this->getPHPCLI() .'" "'. Environment::getBasePath() .'tools'.DIRECTORY_SEPARATOR.'unattended_upgrade.php" --config "'. CONFIG_FILE .'" --requirements_only --web_installer';


Top
 Profile  
 
PostPosted: Mon Dec 01, 2014 2:39 pm 
Offline

Joined: Tue Sep 19, 2006 2:22 pm
Posts: 7278
I will pass this on to our developers, thanks.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Time and Attendance




Powered by phpBB® Forum Software © phpBB Group