Unable to complete installation

Ask your questions regarding TimeTrex installation here.
Post Reply
ventieldopje
Posts: 4
Joined: Thu Jul 25, 2019 2:21 am

Unable to complete installation

Post by ventieldopje »

Assuming this is a new installation, can you try deleting the TimeTrex database and going through the web-based installer again to see if the error persists?
I am having the same problem, I have tried again what you just said by erasing DataBase but then you still have the same problems. Also on other systems tried there you have the same error message.

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Unable to complete installation

Post by mikeb »

We need to confirm if it is in fact the same underlying error or not. Please enable debug logging as described in this FAQ, then try to connect again and attach a copy of the log file here, it should contain a more specific error message.
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

ventieldopje
Posts: 4
Joined: Thu Jul 25, 2019 2:21 am

Re: Unable to complete installation

Post by ventieldopje »

Here you can find the more specific error log
timetrex.log
(1.02 MiB) Downloaded 181 times

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Unable to complete installation

Post by mikeb »

Upon further investigation it appears this is actually a bug in PostgreSQL v9.4.23, v9.5.18, v9.6.14, v10.9 (version you are running) and v11.4. All of which were released on 20-Jun-2019 and the specific bug was introduced by the release note item: "Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when the table has a partial exclusion constraint (Tom Lane)". The bug has already been fixed and is just waiting on the next release of PostgreSQL which is due out in early August 2019.

It only affects new installations of TimeTrex, or upgrades from TimeTrex versions prior to v11.0.0. We are looking at possible work-arounds from our end, but it may not be possible or practical due to the nature of the bug, and in either case will take some time to implement, test and release ourselves.

However installing an earlier point release of Ubuntu 18.04 or downgrading PostgreSQL to 10.8 or earlier would also allow the install to complete. Once the installation is completed you could upgrade to the latest point release and TimeTrex won't be affected anymore.
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

lumirl
Posts: 6
Joined: Mon Jul 29, 2019 8:16 am

Re: Unable to complete installation

Post by lumirl »

Hello but the problem to install TimeTrex is also with the latest version of Postgresql for Ubuntu - psql (11.4 (Ubuntu 11.4-1.pgdg16.04+1))
Still it fails while filling in the main database during the install process.
What is the manual workaround to install it please?
I can't install TimeTrex to test it so I can't put it in our company into a candidate for time tracking SW in the future...
Can you provide an earlier version of TimeTrex that is not affected by this bug?

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Unable to complete installation

Post by mikeb »

lumirl wrote:
Mon Jul 29, 2019 8:23 am
Hello but the problem to install TimeTrex is also with the latest version of Postgresql for Ubuntu - psql (11.4 (Ubuntu 11.4-1.pgdg16.04+1))
Still it fails while filling in the main database during the install process.
What is the manual workaround to install it please?
I can't install TimeTrex to test it so I can't put it in our company into a candidate for time tracking SW in the future...
Can you provide an earlier version of TimeTrex that is not affected by this bug?
The problem isn't with TimeTrex, its with a bug in all of the latest versions of PostgreSQL. Downgrading PostgreSQL by one version (ie: from 11.4 to 11.3) will resolve the issue. We are looking into a possible way to work around the bug in PostgreSQL, but that doesn't change the fact that the problem is with PostgreSQL and not TimeTrex.
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Unable to complete installation

Post by mikeb »

We have posted a quick guide on how to work around the PostgreSQL bug that is affecting new TimeTrex installs here:
viewtopic.php?f=6&t=7837
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

lumirl
Posts: 6
Joined: Mon Jul 29, 2019 8:16 am

Re: Unable to install Timetrex on Ubuntu

Post by lumirl »

Hello,
there is a new version of Postgres 11.4.1 and still I cannot install your timetrex.
I cannot downgrade according your howto because I have Ubunutu 16.04
So what is the workaround for me?

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Unable to install Timetrex on Ubuntu

Post by mikeb »

lumirl wrote:
Mon Aug 05, 2019 2:38 am
Hello,
there is a new version of Postgres 11.4.1 and still I cannot install your timetrex.
I cannot downgrade according your howto because I have Ubunutu 16.04
So what is the workaround for me?
Unfortunately the PostgreSQL community has not yet released a new version that fixes the bug causing TimeTrex to fail during the install/upgrade yet, though its expected to be released soon.
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

mikeb
Posts: 609
Joined: Thu Jul 27, 2006 11:58 am

Re: Unable to complete installation

Post by mikeb »

If you are using the PGDB APT repository, you can download old versions of the PostgreSQL packages (ie: v11.3) from there and install them in a similar way as described in the FAQ.

This link may help to find the files you need to download: http://apt.postgresql.org/pub/repos/apt ... gresql-11/
TimeTrex Community Edition is developed and supported by volunteers.
Help motivate us to continue by showing your appreciation!

Post Reply